Sublime文本中的Unicode组合

Modified on: Fri, 05 Oct 2018 17:40:06 +0800

我无法使用unicode合成( ctrl + shift + u 方法)在Sublime Text 2中输入unicode字符Ubuntu 12.04(Unity)上的(v2.0.1,Build 2217)。要重现,只需打开一个标签即可:

  1. ctrl + shift + u
  2. 输入00B0
  3. 输入
  4. 醇>

    通常会输入度数符号(°)。我不确定某个Sublime命令是否覆盖了这个键绑定,还有其他人能够做到这一点吗?

最佳答案

我刚遇到同样的问题,我无法在任何地方找到答案,但我确实找到了解决方案。问题是Sublime for Linux中的默认键绑定使用ctrl+shift+u命令覆盖soft_redo。要禁用此功能:

  1. 打开默认的键绑定:Preferences > Key Bindings - Default
  2. 搜索ctrl+shift+u并注释掉包含该键绑定的行。例如://{ "keys": ["ctrl+shift+u"], "command": "soft_redo" },。 (可选)如果确实想要soft_redo我不知道这个命令做什么请参阅下面的评论,您可以将其重新映射到不同的键绑定soft_redo功能)。
  3. 保存,你很高兴去!
  4. 醇>

    但请注意,当您完成unicode字符代码时,您需要使用<space>而不是<enter>,因为Sublime有一个<enter>的键绑定。

    编辑:

    由于您无法再轻松编辑Sublime Text 3中的默认键绑定,我建议您使用回答 @布兰登-lockaby。


相关问答

添加新评论