Firefox中的“libavcodec可能是易受攻击的......”消息

Modified on: Sat, 03 Nov 2018 21:40:02 +0800

自上周以来,我几乎在Firefox中打开的每一页都收到以下消息:

  

libavcodev可能易受攻击或不受支持,应该是
  更新播放视频

显然,这只是一个警告,因为我可以正常播放视频。

我试过

sudo apt-get install libavcodec

但此包不存在。

我还做了apt-get updateapt-get upgrade,但邮件仍然存在。

最后,当我使用apt-get autoremove时,它不会返回任何包。

我用Google搜索了这条消息,但没有发现任何类似的内容。

我该怎么做才能消除这条消息?我应该保持警惕吗?

一些信息:

  • Ubuntu 14.04
  • Firefox Developer Edition 51.0a2
作者:James

最佳答案

此处一个>:

  

描述

  
  

之前FFmpeg中的libavcodec / jpeg2000dwt.c中的ff_dwt_decode函数
  2.8.4之前没有验证分解级别的数量
  进行离散小波变换解码,允许远程
  攻击者导致拒绝服务(越界数组访问)或
  通过精心设计的JPEG 2000可能产生未指明的其他影响数据

libav可以通过以下方式安装:

sudo apt-get install libav-tools

ubuntu 14.04使用的libav的版本是9.x,可以升级到11.x,如下所示:

sudo add-apt-repository ppa:heyarje/libav-11
sudo apt-get update
sudo apt-get install libav-tools

执行命令

sudo apt-get update && sudo apt-get upgrade
sudo apt-get dist-upgrade 

升级包。

作者:,GAD3R

相关问答

添加新评论