试图安装pecl Solr扩展,但它需要卷曲

Modified on: Mon, 15 Apr 2019 19:20:02 +0800

当我尝试安装solr-beta时:

pecl install solr-beta

我收到此错误:

pecl / solr需要PHP扩展“curl”
找不到有效的包裹
安装失败

已经安装了curl,当我查看我的phpinfo页面时似乎启用了它。

作者:jnbdz

最佳答案

来自http:// pecl。 php.net/bugs/bug.php?id=17012&edit=1,pecl不识别没有静态编译成php的php模块。因此,如果您使用任何共享库,pecl将忽略它们。

Pecl也忽略了你的php.ini。

  

好消息是如果你有两种简单的方法来安装它
  将curl作为共享扩展名:

  
  

1)pear install pecl / solr

  
  

2)pecl install -n solr

应该安装solr php模块。您必须通过修改php.ini文件来包含solr.so库。

作者:bibstha

相关问答

添加新评论